And then there was a catastrophic hard drive failure

You know that old saying of always have a backup? Well, it’s good advice.

I think the local power transformer exploded, or malfunctioned or couldn’t keep up with the power demands. Either way, it blew out and the whole neighborhood was plunged into darkness. My UPS devices were going mad, and since I had to get up at 5am regardless, I shut everything down. Everything was running fine, but on the reboot of the Web Server, things went a little sideways. Well, a lot sideways. The machine wouldn’t boot to Windows. I tried to do a recovery and it said there was no previous install of Windows. Then the drive started to click and clack. Then it made even more scary grinding noises. As of now, it seems completely dead.

Ironically, a few months ago I was in the process of building a new 2003 server so I could update the original one. It was being done in a virtual machine and I was very close to completing that project, but ran out of time. Work has been very busy and I haven’t circled back around to complete what I started.

Long story short, I had a backup, but from April when I was last working on this. The site was getting backed up, but not all the media content. I sort of neglected to set that up correctly. But I just got the site back up and working by importing the .SQL file for the WordPress database and copying over all the picture galleries.

As of right now there are a few things missing. I’ve lost a gallery or two and some downloadable files didn’t come over. I will have to rebuild those. It won’t take long, but I have to wait until after the weekend. So if you see things missing, well, they are. I’ll put them back as best I can.

For those that are interested, the server recovery was done using PEBuilder and a copy of Windows XP. I told it to use Windows 2003, but that’s what I got. I copied the files across using a 500GB USB drive, as well as a 32GB thumbdrive. The server now sits inside a Virtual Machine. The host is a 6-core, 16GB machine. I don’t know how stable or long term this is, but it’s working for now. I’m sure there will be cringing and eye-rolling, but Windows 7 64-bit is running Windows Server 2003. When you throw common sense out the window, anything is possible.

Other Articles of Interest:

Leave a Reply